[pve-devel] proxmox install script

Nils Privat gismo3303 at gmail.com
Wed Aug 16 11:35:22 CEST 2017


i got some questions about the proxmox-install-script:
https://git.proxmox.com/?p=pve-installer.git;a=blob_plain;f=proxinstall;hb=HEAD

1) line 21: should be 5.0 ?
2) line 781: small typo 'install'

3) A question regarding function "zfs_create_rpool" (line 761):
Wouldn't it be better to define/check the "compress", "checksum", and
"copies" first and then
create the pool with all the properties similar like chapter 2.3
rather then setting each propterty step by step after creation, see
(https://github.com/zfsonlinux/zfs/wiki/Debian-Stretch-Root-on-ZFS).
So what i mean is something like that after you specify the ashift in line 766:

ashift..line 766...
# disable atime during install
$cmd .= " -O atime=off"

#compression
$cmd .= " -O compression=$config_options->{compress}"

....etc

The same for checksum and copies and after setting all into $cmd we
run at the end: zpool create..$cmd...
So the last entries/lines in that function with my $value are obsolet.


4) The link above on github (debian stretch root on zfs) also suggests
always using '/dev/disk/by-id/*' and not '/dev/sd*'.
But when i run the installer/boot from ISO to install proxmox i get a
list of disks like '/dev/sd*' or when i run zpool status the rpool is
/dev/sda .... Normally, on non-root-pools, we can change that via
export import but on a rpool?! So did i something wrong or does the
install script using /dev/sd*?

5) Regarding the function 'partition_bootable_zfs_disk' on line 913:
As far as i can see the partition schema isnt like the recommended on
the link above (see chapter 2.2). There i dont see a  -part9 on rpool
pools. And just for your information: there are currently some
discussions on ZoL-github to may remove the -part9 and add a new pool
proptery.

6) just a dump question on line 944: my $os_size = $hdsize - 1024 - 1024*8;
I quess the 8M is the -part9 and what are the 1024? Shouldn't it be
2048 (2K) because the legacy/BIOS -part1 is 2K?


More information about the pve-devel mailing list