[pve-devel] [PATCH manager 1/2] fix securitygroupselector

Dominik Csapak d.csapak at proxmox.com
Tue Apr 26 11:32:43 CEST 2016


move the display and value field into class definition,
to make it work again

Signed-off-by: Dominik Csapak <d.csapak at proxmox.com>
---
 www/manager6/form/SecurityGroupSelector.js | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/www/manager6/form/SecurityGroupSelector.js b/www/manager6/form/SecurityGroupSelector.js
index 37e6bac..c3a42dc 100644
--- a/www/manager6/form/SecurityGroupSelector.js
+++ b/www/manager6/form/SecurityGroupSelector.js
@@ -2,6 +2,8 @@ Ext.define('PVE.form.SecurityGroupsSelector', {
     extend: 'PVE.form.ComboGrid',
     alias: ['widget.pveSecurityGroupsSelector'],
 
+    valueField: 'group',
+    displayField: 'group',
     initComponent: function() {
 	var me = this;
 
@@ -21,8 +23,6 @@ Ext.define('PVE.form.SecurityGroupsSelector', {
 
 	Ext.apply(me, {
 	    store: store,
-	    valueField: 'group',
-	    displayField: 'group',
             listConfig: {
 		columns: [
 		    {
-- 
2.1.4




More information about the pve-devel mailing list