[pve-devel] proxmox 3->4 cluster upgrade : corosync2 wheezy transition package ?

Dietmar Maurer dietmar at proxmox.com
Sat Oct 3 10:05:49 CEST 2015



> On October 3, 2015 at 9:42 AM Dietmar Maurer <dietmar at proxmox.com> wrote:
> 
> 
> > > I wonder if it could be great (ad possible? )to make a corosync2
> > > transition
> > > package for wheezy.
> > > 
> > > Like this we could mix (proxmox3-wheezy-corosync2  and
> > > proxmox4-jessie-corosync2),
> > > and do live migration as usual.
> > > 
> > > 
> > > What do you think about it ?
> > 
> > How should that work? corosync2 is not compatible with corosync 1.4, so
> > what is the idea?
> 
> Oh, you want to backport corosync2 to wheezy? Need to think about that.

You need to update at least 3 packages for that:

- libqb
- corosync
- pve-cluster

and that update will have bad side effects for all other cluster related
packages

- redhat-cluster-pve
- openais
- clvmd
- anything else?

This looks really complex to me?



More information about the pve-devel mailing list