[pve-devel] Length mismatch: 0000:00:12.0/virtio-net-pci.rom: 0x10000 in != 0x40000

Stefan Priebe - Profihost AG s.priebe at profihost.ag
Thu Nov 19 08:12:11 CET 2015


Am 18.11.2015 um 16:32 schrieb Alexandre DERUMIER:
>>> Ah thanks - why do we need so complex code? Couldn't we simply use the 
>>> machine type we already force on migration and pass? If somebody is 
>>> using machine type 2.2 or 2.3 he can't have efi. An we already query the 
>>> machine code through qmp on each migration. 
> 
> Dietmar has made change on qemu 2.4, but after release of proxmox 4.0.
> 
> so we have qemu 2.4 with pxe and qemu 2.4 with efi.

ah OK thanks.

Stefan

> ----- Mail original -----
> De: "Stefan Priebe" <s.priebe at profihost.ag>
> À: "pve-devel" <pve-devel at pve.proxmox.com>
> Envoyé: Mercredi 18 Novembre 2015 15:55:18
> Objet: Re: [pve-devel] Length mismatch: 0000:00:12.0/virtio-net-pci.rom: 0x10000 in != 0x40000
> 
> Am 18.11.2015 um 15:35 schrieb Alexandre DERUMIER: 
>> is it qemu 2.4 on proxmox4 ? 
>> or do you have backported it from proxmox git to proxmox 3 ? 
>>
>> recently, we have switched network card pxe roms to efi roms, 
>> and I have add a fix to qemu-server to keep old pxe roms in case of migration 
>>
>> They are multiple commits, but first commit is: 
>> https://git.proxmox.com/?p=qemu-server.git;a=commit;h=ba9e10002f92ba31d157ddc2cf2c38a0472d725b 
> 
> Ah thanks - why do we need so complex code? Couldn't we simply use the 
> machine type we already force on migration and pass? If somebody is 
> using machine type 2.2 or 2.3 he can't have efi. An we already query the 
> machine code through qmp on each migration. 
> 
> Stefan 
> 
>> ----- Mail original ----- 
>> De: "Stefan Priebe" <s.priebe at profihost.ag> 
>> À: "pve-devel" <pve-devel at pve.proxmox.com> 
>> Envoyé: Mercredi 18 Novembre 2015 13:27:25 
>> Objet: [pve-devel] Length mismatch: 0000:00:12.0/virtio-net-pci.rom: 0x10000 in != 0x40000 
>>
>> Hi, 
>>
>> i've upgrade some systems from qemu 2.2 to 2.4 and was trying to migrate 
>> those VMs. 
>>
>> But those migrations fail with: 
>> kvm: Length mismatch: 0000:00:12.0/virtio-net-pci.rom: 0x10000 in != 
>> 0x40000: Invalid argument 
>> kvm: error while loading state for instance 0x0 of device 'ram' 
>>
>> Is this a known bug? 
>>
>> Stefan 
>> _______________________________________________ 
>> pve-devel mailing list 
>> pve-devel at pve.proxmox.com 
>> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 
>> _______________________________________________ 
>> pve-devel mailing list 
>> pve-devel at pve.proxmox.com 
>> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 
>>
> _______________________________________________ 
> pve-devel mailing list 
> pve-devel at pve.proxmox.com 
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 
> _______________________________________________
> pve-devel mailing list
> pve-devel at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel
> 


More information about the pve-devel mailing list