[pve-devel] Default cache mode for VM hard drives

Stanislav German-Evtushenko ginermail at gmail.com
Thu May 28 20:20:19 CEST 2015


On May 28, 2015 8:12 PM, "Stanislav German-Evtushenko" <ginermail@
<ginermail at gmail.com>gmail.com <ginermail at gmail.com>> wrote:
>
> > Your test code was a really interesting example, and lead to
> > really unexpected results (at least for me). But as Eneko already
> > mentioned, nobody would write such code. It is simply not thread save,
> > and I think qemu does it correctly.
>
> I have written that code only because nobody wanted to test real-life
> test cases I had provided (VM with low memory and Windows 7 inside).
> However now I think it is going to be even easier to reproduce in a
> VM. My guess if you install a VM with virtual drive on DRBD or MD RAID
> and cache=none, create ext3 or ext4 partition inside this VM and run
> my code inside then you will get inconsistence. May be you need to run
> it not once but 10-20 times but finally it should happen.
>
> Stanislav

Also I want to mentioned that I started to write that C-code because of the
following message in logs which clearly stated what happened:

Jun 14 08:50:12 kvm5 kernel: block drbd0: Digest mismatch, buffer modified
by upper layers during write: 21158352s +4096
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-devel/attachments/20150528/8214ae74/attachment.html>


More information about the pve-devel mailing list