[pve-devel] Grub problems and ZFS

Michael Rasmussen mir at datanom.net
Wed May 20 19:43:53 CEST 2015


Hi all,

I might have found the cause for the sometimes failing grub install. As
I updated the grub packages today I discovered very extended install
time for the grub package which was related to the post-install script.
The script ran for several minuttes and while running consuming a full
core 100%.

The cause for this was strictly related to the package os-prober which
is used to find additional OS's and when you have attached a big
number of iSCSI LUNs for KVM and/or CT storage this means that
os-prober will scan all available connected LUNs for additional OS's.

Could this be the cause for failing grub install?

As a side note os-prober is completely useless on a bare-metal
installer and I think installing proxmox on top of Debian should remove
this package too?

-- 
Hilsen/Regards
Michael Rasmussen

Get my public GnuPG keys:
michael <at> rasmussen <dot> cc
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xD3C9A00E
mir <at> datanom <dot> net
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE501F51C
mir <at> miras <dot> org
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE3E80917
--------------------------------------------------------------
/usr/games/fortune -es says:
For recreational use only.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: OpenPGP digital signature
URL: <http://pve.proxmox.com/pipermail/pve-devel/attachments/20150520/71c082b5/attachment.sig>


More information about the pve-devel mailing list