[pve-devel] [PATCH 2/3] ext5migrate: fix display of PVE version underneath product name

Emmanuel Kasper e.kasper at proxmox.com
Tue May 19 08:37:00 CEST 2015


With the alignment set to 'middle' in the north region, the 'versioninfo'
component was wrongly pushed downwards, hiding the version string.
Besides that we need to manually set a 'height' argument
to 'versioninfo' equal to the size of the north region, to prevent extjs to
generate a problematic padding.
---
 www/manager5/Workspace.js | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/www/manager5/Workspace.js b/www/manager5/Workspace.js
index 5a31e8d..4e9e2e0 100644
--- a/www/manager5/Workspace.js
+++ b/www/manager5/Workspace.js
@@ -364,7 +364,6 @@ Ext.define('PVE.StdWorkspace', {
 		    height: 30,
 		    layout: { 
 			type: 'hbox',
-			align : 'middle'
 		    },
 		    baseCls: 'x-plain',		
 		    defaults: {
@@ -382,7 +381,8 @@ Ext.define('PVE.StdWorkspace', {
 			    minWidth: 200,
 			    flex: 1,
 			    id: 'versioninfo',
-			    html: '<span class="x-panel-header-text">Proxmox Virtual Environment</span>'
+			    html: '<span class="x-panel-header-text">Proxmox Virtual Environment</span>',
+			    height: 30
 			},
 			{
 			    pack: 'end',
-- 
2.1.4




More information about the pve-devel mailing list