[pve-devel] Kernel module woes

Michael Rasmussen mir at datanom.net
Sun May 3 12:31:33 CEST 2015


Hi Dietmar,

I am trying to help Patrick from servethehome.org to make his fusionIO
drivers compile on proxmox-3.4 with kern 2.6.32-37-pve but has run into
a bit of a problem. The problem is that even though Sandisk provides
sources this is not a real source tree since the source package for
each supported distro comes with one binary blob compiled against the
distros stock kernel (for Debian Wheezy):
KFIO_LIB=kfio/x86_64_cc47_libkfio.o_shipped 

The driver builds and installs fine but due to the linked in binary
blob the driver wont load giving this error message in syslog:
intel-e5-2699v3 kernel: iomemory_vsl: disagrees about version of symbol
module_layout

I have tried to swap the binary blob from the RHEL source tree but the
same error persists.

Any idea what to do besides trying to persuade Sandisk to produce a
proper source tree?

-- 
Hilsen/Regards
Michael Rasmussen

Get my public GnuPG keys:
michael <at> rasmussen <dot> cc
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xD3C9A00E
mir <at> datanom <dot> net
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE501F51C
mir <at> miras <dot> org
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE3E80917
--------------------------------------------------------------
/usr/games/fortune -es says:
I'll be comfortable on the couch.  Famous last words.
		-- Lenny Bruce
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: OpenPGP digital signature
URL: <http://pve.proxmox.com/pipermail/pve-devel/attachments/20150503/e50496c1/attachment.sig>


More information about the pve-devel mailing list