[pve-devel] [PATCH] add ovmf uefi roms support

Alexandre DERUMIER aderumier at odiso.com
Wed Dec 9 16:35:32 CET 2015


>>Also, maybe ovmf try to found 
>>
>>\EFI\Boot\bootx64.efi 

This is to be the case,
simply

mkdir /boot/efi/boot
cp /boot/efi/proxmox/grubx64.efi /boot/efi/boot/bootx64.efi 

make it bootable.

(It's bypass grub in this case I think)



So, I can confirm that ovmf is working fine.
I'm not expert with uefi implementation, maybe ovmf don't implement all , and only bootx64.efi.

So I think you can add the patch to proxmox git.



----- Mail original -----
De: "aderumier" <aderumier at odiso.com>
À: "pve-devel" <pve-devel at pve.proxmox.com>
Envoyé: Mercredi 9 Décembre 2015 16:22:33
Objet: Re: [pve-devel] [PATCH] add ovmf uefi roms support

seem that archlinux use systemd-boot 

https://wiki.archlinux.org/index.php/Systemd-boot 

vs grub for proxmox iso. 


Also, maybe ovmf try to found 

\EFI\Boot\bootx64.efi 

which is available on archlinux install 


but on proxmox install it's: 

/efi/proxmox/grubx64.efi 

----- Mail original ----- 
De: "aderumier" <aderumier at odiso.com> 
À: "pve-devel" <pve-devel at pve.proxmox.com> 
Envoyé: Mercredi 9 Décembre 2015 16:07:15 
Objet: Re: [pve-devel] [PATCH] add ovmf uefi roms support 

don't boot with proxmox 4.0 iso install. 

Don't known what is the difference with archlinux, 
but it seem to be a proxmox uefi install problem. 

I'll try to see the difference between both. 


----- Mail original ----- 
De: "aderumier" <aderumier at odiso.com> 
À: "pve-devel" <pve-devel at pve.proxmox.com> 
Envoyé: Mercredi 9 Décembre 2015 15:55:58 
Objet: Re: [pve-devel] [PATCH] add ovmf uefi roms support 

works fine with archlinux 

https://wiki.archlinux.org/index.php/Beginners'_guide 




----- Mail original ----- 
De: "aderumier" <aderumier at odiso.com> 
À: "dietmar" <dietmar at proxmox.com> 
Cc: "pve-devel" <pve-devel at pve.proxmox.com> 
Envoyé: Mercredi 9 Décembre 2015 15:09:54 
Objet: Re: [pve-devel] [PATCH] add ovmf uefi roms support 

>>Note: The qemu patch is still not applied, because I wait for feedback. 

ok, I'll try it today with a proxmox guest install and archlinux install 

----- Mail original ----- 
De: "dietmar" <dietmar at proxmox.com> 
À: "aderumier" <aderumier at odiso.com> 
Cc: "pve-devel" <pve-devel at pve.proxmox.com> 
Envoyé: Mercredi 9 Décembre 2015 10:59:15 
Objet: Re: [pve-devel] [PATCH] add ovmf uefi roms support 

> On November 26, 2015 at 9:25 AM Alexandre DERUMIER <aderumier at odiso.com> 
> wrote: 
> 
> 
> >>But it is still not working for me. I tested with a normal PVE install CD, 
> >>and the OVMF Bios is unable to boot that disk, although we create an EFI 
> >>boot partition?? 
> 
> I'll try with PVE install CD as guest. (windows works 100%) 

Note: The qemu patch is still not applied, because I wait for feedback. 

_______________________________________________ 
pve-devel mailing list 
pve-devel at pve.proxmox.com 
http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 
_______________________________________________ 
pve-devel mailing list 
pve-devel at pve.proxmox.com 
http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 

_______________________________________________ 
pve-devel mailing list 
pve-devel at pve.proxmox.com 
http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 
_______________________________________________ 
pve-devel mailing list 
pve-devel at pve.proxmox.com 
http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 


More information about the pve-devel mailing list