[pve-devel] [PATCH container] improve some 'implement me' error messages

Wolfgang Bumiller w.bumiller at proxmox.com
Mon Dec 7 15:12:46 CET 2015


---
 src/PVE/LXC.pm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/PVE/LXC.pm b/src/PVE/LXC.pm
index 38ce71c..159ac1c 100644
--- a/src/PVE/LXC.pm
+++ b/src/PVE/LXC.pm
@@ -1078,7 +1078,7 @@ sub update_lxc_config {
 	    $raw .= "lxc.include = /usr/share/lxc/config/$ostype.userns.conf\n"
 	}
     } else {
-	die "implement me";
+	die "implement me (ostype $ostype)";
     }
 
     $raw .= "lxc.monitor.unshare = 1\n";
@@ -1264,7 +1264,7 @@ sub update_pct_config {
 	    } elsif ($opt eq 'unprivileged') {
 		die "unable to delete read-only option: '$opt'\n";
 	    } else {
-		die "implement me"
+		die "implement me (delete: $opt)"
 	    }
 	    write_config($vmid, $conf) if $running;
 	}
-- 
2.1.4




More information about the pve-devel mailing list