[pve-devel] qemu 2.1 released

Alexandre DERUMIER aderumier at odiso.com
Wed Aug 6 13:36:06 CEST 2014


(reproduced with simple local disk, no nfs or ceph)


----- Mail original ----- 

De: "Alexandre DERUMIER" <aderumier at odiso.com> 
À: "Martin Maurer" <martin at proxmox.com> 
Cc: "pve-devel" <pve-devel at pve.proxmox.com> 
Envoyé: Mercredi 6 Août 2014 13:35:16 
Objet: Re: [pve-devel] qemu 2.1 released 

I can reproduce it too, 

First snapshot works, but second snapshot hang, crash the qemu process 


Maybe it's a bug in internal-snapshot-async.patch. 



----- Mail original ----- 

De: "Martin Maurer" <martin at proxmox.com> 
À: "Alexandre DERUMIER" <aderumier at odiso.com>, "Dietmar Maurer" <dietmar at proxmox.com> 
Cc: "pve-devel" <pve-devel at pve.proxmox.com> 
Envoyé: Mercredi 6 Août 2014 12:57:18 
Objet: RE: [pve-devel] qemu 2.1 released 

> Subject: Re: [pve-devel] qemu 2.1 released 
> 
> Just to be sure, it's taking snapshot which fail ? 
> 
> or the snapshot is corrupt and we rollback hang ? 

Creating one snapshots with RAM works, just try to create a second one with RAM after a few seconds fails with: 
__ 
Formatting '/var/lib/vz/images/100/vm-100-state-ram5.raw', fmt=raw size=4819255296 
TASK ERROR: VM 100 qmp command 'savevm-start' failed - client closed connection 
__ 

And the VM is stopped. I see this with local qcow2 storage, but also on ceph. 

Second issue: 
Creating a snapshot on NFS (qcow2 on NFS) seems to hangs forever with the snapstate "prepare" and the task log shows "Formatting '/mnt/pve/store-nfs /images/119/vm-119-state-ram1.raw', fmt=raw size=2671771648" 

Martin 
_______________________________________________ 
pve-devel mailing list 
pve-devel at pve.proxmox.com 
http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 


More information about the pve-devel mailing list