[pve-devel] Solaris: no working network solved

Alexandre DERUMIER aderumier at odiso.com
Mon Sep 23 06:10:15 CEST 2013


Hi,

Seem to be a bug in solaris to handle x2apic.

I think we could also have this problem with host cpu model, or some other cpu model (nahelem,...) which have x2apic enabled by default.

Maybe could we introduce some cpu flags override on cpu option ?  (-+x2apic, +- any other cpu flags).

So users could setup custom flags for specials case withtout hacking with args option.

?




----- Mail original ----- 

De: "Michael Rasmussen" <mir at datanom.net> 
À: pve-devel at pve.proxmox.com 
Envoyé: Dimanche 22 Septembre 2013 19:53:53 
Objet: Re: [pve-devel] Solaris: no working network solved 

On Sun, 22 Sep 2013 19:14:57 +0200 
Michael Rasmussen <mir at datanom.net> wrote: 

> Hi all, 
> 
> I seem to have found a bug in the cpu option for running solaris based 
> guest over kvm. 
> 
> Currently the cpu option looks likes this: -cpu <cpu type>,+x2apic 
> This causes a no working network. 
> Using this instead: -cpu <cpu type> 
> Eg. remove the +x2apic resolves the bug an a working network is the 
> result. 
> 
Removing +x2apic also means no complains of not working uhci and with 
latest bloody sata is available for installation. 

-- 
Hilsen/Regards 
Michael Rasmussen 

Get my public GnuPG keys: 
michael <at> rasmussen <dot> cc 
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xD3C9A00E 
mir <at> datanom <dot> net 
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE501F51C 
mir <at> miras <dot> org 
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE3E80917 
-------------------------------------------------------------- 
Murray's Rule: 
Any country with "democratic" in the title isn't. 

_______________________________________________ 
pve-devel mailing list 
pve-devel at pve.proxmox.com 
http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 


More information about the pve-devel mailing list