[pve-devel] qemu 1.7 usbX does not work

Dietmar Maurer dietmar at proxmox.com
Fri Dec 6 19:01:14 CET 2013


> > i noticed that something like:
> > usb0: host=2-1.3
> >
> > does not work anymore:
> > kvm: -device usb-host,hostbus=2,hostport=1.3: Parameter 'driver'
> > expects device type
> 
> ok this is due to the fact that qemu 1.7 checks for libusb at least
> 1.0.13 (pkg-config --atleast-version=1.0.13 libusb-1.0) but debian wheezy only
> provides 1.0.11.

many thanks for the bug report!

> Would we like to patch configure script hoping that debian backported the
> relevant fixes?

I just back ported the jessie packages to wheezy:

https://git.proxmox.com/?p=libusb.git;a=summary

https://git.proxmox.com/?p=pve-qemu-kvm.git;a=commitdiff;h=eefac8da9acfee621936f4162be711b7c7c211be

Please can you test?



More information about the pve-devel mailing list