[pve-devel] qemu-img convert crashes

Stefan Priebe - Profihost AG s.priebe at profihost.ag
Tue Apr 16 15:32:00 CEST 2013


Am 16.04.2013 15:22, schrieb Alexandre DERUMIER:
>>> Also a segfault. 
> 
> Do you have tried with another rbd source volume ? Do you use stable ceph bobtail ?

Both yes always the same result... wouldn't it make sense to use rbd cp
instead?

> 
> ----- Mail original ----- 
> 
> De: "Stefan Priebe - Profihost AG" <s.priebe at profihost.ag> 
> À: "Alexandre DERUMIER" <aderumier at odiso.com> 
> Cc: pve-devel at pve.proxmox.com, "Dietmar Maurer" <dietmar at proxmox.com> 
> Envoyé: Mardi 16 Avril 2013 14:51:19 
> Objet: Re: [pve-devel] qemu-img convert crashes 
> 
> Am 16.04.2013 14:42, schrieb Alexandre DERUMIER: 
>> oh, I never try to clone(copy) between 2 rbd storage, only from local to rbd , or rbd to local. 
>>
>> maybe can you try without '-t writeback ?' 
> Same. 
> 
>> Does it work if you try to copy from rbd to local by example ? 
> Also a segfault. 
> 
> I'm using: pve-qemu-kvm 1.4-6 
> 
> Stefan 
> 
> 
>> ----- Mail original ----- 
>>
>> De: "Stefan Priebe - Profihost AG" <s.priebe at profihost.ag> 
>> À: "Alexandre DERUMIER" <aderumier at odiso.com> 
>> Cc: pve-devel at pve.proxmox.com, "Dietmar Maurer" <dietmar at proxmox.com> 
>> Envoyé: Mardi 16 Avril 2013 14:36:50 
>> Objet: Re: [pve-devel] qemu-img convert crashes 
>>
>> HI, 
>>
>> here is the crash when trying to clone: 
>>
>> activate volume source vmstorssd1:vm-166-disk-1 
>> create target volume 
>> activate volume vmstorssd1:vm-169-disk-1 
>> copy vmstorssd1:vm-166-disk-1 to vmstorssd1:vm-169-disk-1 
>> (0.00/100%) 
>> TASK ERROR: create failed - copy failed: command '/usr/bin/qemu-img 
>> convert -t writeback -p -C -f rbd -O rbd 
>> 'rbd:vmstorssd1/vm-166-disk-1:mon_host=10.255.0.100\:6789\;10.255.0.101\:6789\;10.255.0.102\:6789\;:auth_supported=none' 
>> 'rbd:vmstorssd1/vm-169-disk-1:mon_host=10.255.0.100\:6789\;10.255.0.101\:6789\;10.255.0.102\:6789\;:auth_supported=none'' 
>> failed: got signal 1 
>>
>> Stefan 
>>
>> Am 16.04.2013 13:17, schrieb Stefan Priebe - Profihost AG: 
>>> Hi, 
>>>
>>> will recheck that. 
>>>
>>> Right now i want to create a template. But nothing happens.If i convert 
>>> a Machine into a template i just see a task qmtemplate => OK. That's 
>>> all. But the VM stays the same and i can still start / stop that one. 
>>>
>>> Greets, 
>>> Stefan 
>>>
>>> Am 16.04.2013 12:28, schrieb Alexandre DERUMIER: 
>>>>>> Then i'll wait until these patches get integrated. Right now qemu-img 
>>>>>> segfaults with rbd for me when trying to clone. 
>>>>
>>>> Could you describe the problem ? I have tested it last month and it was working fine. 
>>>>
>>>> (Just to be sure, you don't try to use qemu-img on a running vm, because it don't work) 
>>>>
>>>> ----- Mail original ----- 
>>>>
>>>> De: "Stefan Priebe - Profihost AG" <s.priebe at profihost.ag> 
>>>> À: "Dietmar Maurer" <dietmar at proxmox.com> 
>>>> Cc: pve-devel at pve.proxmox.com 
>>>> Envoyé: Mardi 16 Avril 2013 11:04:39 
>>>> Objet: Re: [pve-devel] Feature HW Profiles 
>>>>
>>>> Hi, 
>>>> Am 16.04.2013 10:58, schrieb Dietmar Maurer: 
>>>>>>> VM templates will provide a way to do that (patches from Alexandre). 
>>>>>>
>>>>>> Yes and no as the disk will be also cloned. I'm just speaking about the settings 
>>>>>> like in OpenStack, OpenNebula and others. 
>>>>>
>>>>> We can also allow to create templates without any disks. You can then add the disks when you clone. 
>>>>
>>>> oh OK sorry. 
>>>>
>>>> Then i'll wait until these patches get integrated. Right now qemu-img 
>>>> segfaults with rbd for me when trying to clone. 
>>>>
>>>> Thanks! 
>>>>
>>>> Greets Stefan 
>>>>
>>>>
>>>> _______________________________________________ 
>>>> pve-devel mailing list 
>>>> pve-devel at pve.proxmox.com 
>>>> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 
>>>>


More information about the pve-devel mailing list