[pve-devel] vnc viewer (kvm) not working after wheezy update

Alexandre DERUMIER aderumier at odiso.com
Sat Apr 6 09:10:52 CEST 2013


Hi Martin,

Indeed it's works with ip address.


I'm using archlinux with sun java 7. I have the problem with all browsers (firefox,chrome,chromium)

I had tried to delete the java cache, but it doesn't change nothing. Only ip address works.


----- Mail original ----- 

De: "Martin Maurer" <martin at proxmox.com> 
À: "Alexandre DERUMIER" <aderumier at odiso.com> 
Cc: pve-devel at pve.proxmox.com 
Envoyé: Vendredi 5 Avril 2013 12:10:07 
Objet: RE: [pve-devel] vnc viewer (kvm) not working after wheezy update 

> Subject: [pve-devel] vnc viewer (kvm) not working after wheezy update 
> 
> Hi, 
> 
> I have upgraded 2 nodes to wheezy, all seem to works fine, except vnc 
> console (I'm only test kvm). 
> 
> I got a java error : ClassNotFoudnException : 
> com.tigervnc.vncviewer.VncViewer. 
> 
> 
> 
> Also the refresh link, thrown a javascript exception in my firebug: 
> 
> 
> TypeError: applet.sendRefreshRequest is not a function 
> 
> applet.sendRefreshRequest(); 
> 
> pvemanagerlib.js (ligne 2026) 

Does it work if you access via IP instead of hostname (https://IP-of-PVE3:8006) 

I had some weird java messages, finally solved by removing all cached certificates in the local java installation. Which browser/desktop OS/java combination do you run? 

Martin 


More information about the pve-devel mailing list