[pve-devel] qemu-server changes

Alexandre DERUMIER aderumier at odiso.com
Sun Feb 5 10:30:17 CET 2012


> I made some tests, and something goes wrong when hotplug fail. 
> 
> The config file is written even if hotplug die. 

>>Yes, that change was intentional (to simplify the code). 
>>
>>IMHO hotplug should not fail. And if it fails the state of the VM 
>>is somehow undefined, and it is better to have the change in 
>>the config file so that it work on next boot. 
>>
>>Else a device simply vanish from the configuration, and this is 
>>very confusing on the GUI! 

ok, I understand what you mean.

My point was that config file should reflect what is really plugged in running vm.
For me, that's more confusing to display a device in gui, if it not really yet available until next reboot.

Also, if hotplug fail, and device is in conf, we cannot retry to hotplug it or unplug it,without manual config file edit to remove it.


>>What can make hotplug fail exactly (beside bugs in KVM)? 

mmm,indeed, I didn't see a hotplug/unplug fail since a while...(doesn't see it with qemu 1.0 I think).




So maybe can we try like this, and see if it's works fine for proxmox users ?
 





-- 

-- 




	
	Alexandre Derumier 
Ingénieur système 
e-mail : aderumier at odiso.com 
Tél : +33 (0)3 20 68 88 90 
Fax : +33 (0)3 20 68 90 81 
45 Bvd du Général Leclerc 
59100 ROUBAIX - FRANCE 













-------------- next part --------------
A non-text attachment was scrubbed...
Name: aderumier.vcf
Type: text/x-vcard
Size: 183 bytes
Desc: not available
URL: <http://pve.proxmox.com/cgi-bin/mailman/private/pve-devel/attachments/20120205/df5d5c10/attachment.vcf>


More information about the pve-devel mailing list