[pve-devel] pve-kernel-2.6.32 :(squeeze-proxmox2): broadcom bnx2 firmware load error

Alexandre DERUMIER aderumier at odiso.com
Thu Aug 25 08:20:58 CEST 2011


I'm trying the pve-kernel-2.6.32 from git (redhat src 131.6.1.el6 based), can't load the bnx2 firmware.

bnx2: Broadcom NetXtreme II Gigabit Ethernet Driver bnx2 v2.1.6 (Mar 7, 2011)
bnx2 0000:05:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
bnx2 0000:05:00.0: firmware: requesting bnx2/bnx2-mips-06-6.2.1.fw
bnx2: Can't load firmware file "bnx2/bnx2-mips-06-6.2.1.fw"


firmware is correctly installed

kvmtest:~# stat /lib/firmware/bnx2/bnx2-mips-06-6.2.1.fw
  File: `/lib/firmware/bnx2/bnx2-mips-06-6.2.1.fw'
  Size: 92792           Blocks: 192        IO Block: 4096   regular file
Device: fd00h/64768d    Inode: 2335586     Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2011-08-25 07:03:26.000000000 +0200
Modify: 2011-08-25 05:58:57.000000000 +0200
Change: 2011-08-25 07:03:27.000000000 +0200



same kernel works fine on lenny (but load an another firmware)


I see a similar bugreport on redhat bugzilla 

https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=678429

I'll try to investigated a little more


More information about the pve-devel mailing list