[pve-devel] r6429 - in pve-common/trunk: . data data/PVE debian

svn-commits at proxmox.com svn-commits at proxmox.com
Fri Aug 5 12:41:02 CEST 2011


Author: dietmar
Date: 2011-08-05 12:41:02 +0200 (Fri, 05 Aug 2011)
New Revision: 6429

Modified:
   pve-common/trunk/Makefile
   pve-common/trunk/data/ChangeLog
   pve-common/trunk/data/PVE/CLIHandler.pm
   pve-common/trunk/debian/changelog
Log:
fix CLIHandler.pm


Modified: pve-common/trunk/Makefile
===================================================================
--- pve-common/trunk/Makefile	2011-08-05 10:33:03 UTC (rev 6428)
+++ pve-common/trunk/Makefile	2011-08-05 10:41:02 UTC (rev 6429)
@@ -1,7 +1,7 @@
 RELEASE=2.0
 
 VERSION=1.0
-PKGREL=2
+PKGREL=3
 
 PACKAGE=libpve-common-perl
 

Modified: pve-common/trunk/data/ChangeLog
===================================================================
--- pve-common/trunk/data/ChangeLog	2011-08-05 10:33:03 UTC (rev 6428)
+++ pve-common/trunk/data/ChangeLog	2011-08-05 10:41:02 UTC (rev 6429)
@@ -1,3 +1,7 @@
+2011-08-05  Proxmox Support Team  <support at proxmox.com>
+
+	* PVE/CLIHandler.pm (help): avoid warning on undefined commands
+
 2011-08-02  Proxmox Support Team  <support at proxmox.com>
 
 	* PVE/CLIHandler.pm (handle_cmd): auto-complete commands

Modified: pve-common/trunk/data/PVE/CLIHandler.pm
===================================================================
--- pve-common/trunk/data/PVE/CLIHandler.pm	2011-08-05 10:33:03 UTC (rev 6428)
+++ pve-common/trunk/data/PVE/CLIHandler.pm	2011-08-05 10:41:02 UTC (rev 6429)
@@ -52,7 +52,7 @@
 	    return undef;
 	}
 
-	my ($class, $name, $arg_param, $uri_param) = @{$cmddef->{$cmd}};
+	my ($class, $name, $arg_param, $uri_param) = @{$cmddef->{$cmd} || []};
 
 	raise_param_exc({ cmd => "no such command '$cmd'"}) if !$class;
 

Modified: pve-common/trunk/debian/changelog
===================================================================
--- pve-common/trunk/debian/changelog	2011-08-05 10:33:03 UTC (rev 6428)
+++ pve-common/trunk/debian/changelog	2011-08-05 10:41:02 UTC (rev 6429)
@@ -1,3 +1,9 @@
+libpve-common-perl (1.0-3) unstable; urgency=low
+
+  * fix CLIHandler.pm
+
+ -- Proxmox Support Team <support at proxmox.com>  Fri, 05 Aug 2011 12:40:17 +0200
+
 libpve-common-perl (1.0-2) unstable; urgency=low
 
   * depend on liburi-perl



More information about the pve-devel mailing list