[pve-devel] r5029 - dab/trunk

svn-commits at proxmox.com svn-commits at proxmox.com
Thu Aug 19 09:00:48 CEST 2010


Author: dietmar
Date: 2010-08-19 07:00:48 +0000 (Thu, 19 Aug 2010)
New Revision: 5029

Modified:
   dab/trunk/DAB.pm
   dab/trunk/Makefile
   dab/trunk/changelog.Debian
Log:
fix task-mysql


Modified: dab/trunk/DAB.pm
===================================================================
--- dab/trunk/DAB.pm	2010-08-17 14:01:38 UTC (rev 5028)
+++ dab/trunk/DAB.pm	2010-08-19 07:00:48 UTC (rev 5029)
@@ -1486,9 +1486,18 @@
 sub ve_mysql_bootstrap {
     my ($self, $sql, $password) = @_;
 
-    my $cmd = "/usr/sbin/mysqld --bootstrap --user=mysql --skip-grant-tables " .
-	"--skip-bdb  --skip-innodb --skip-ndbcluster";
+    my $cmd;
 
+    my $suite = $self->{config}->{suite};
+ 
+    if ($suite eq 'squeeze') {
+	$cmd = "/usr/sbin/mysqld --bootstrap --user=mysql --skip-grant-tables";
+
+    } else {
+	$cmd = "/usr/sbin/mysqld --bootstrap --user=mysql --skip-grant-tables " .
+	    "--skip-bdb  --skip-innodb --skip-ndbcluster";
+    }
+
     $self->ve_command ($cmd, $sql);
 }
 
@@ -1539,8 +1548,12 @@
     my $password = $opts->{password};
     my $rootdir = $self->vz_root_dir();
 
-    my $required = $self->compute_required ([qw (mysql-common mysql-server-5.0)]);
+    my $suite = $self->{config}->{suite};
+    
+    my $ver = $suite eq 'squeeze' ? '5.1' : '5.0';
 
+    my $required = $self->compute_required (['mysql-common', "mysql-server-$ver"]);
+
     $self->cache_packages ($required);
  
     $self->ve_dpkg ('install', @$required);

Modified: dab/trunk/Makefile
===================================================================
--- dab/trunk/Makefile	2010-08-17 14:01:38 UTC (rev 5028)
+++ dab/trunk/Makefile	2010-08-19 07:00:48 UTC (rev 5029)
@@ -1,6 +1,6 @@
 VERSION=1.1
 PACKAGE=dab
-PKGREL=5
+PKGREL=6
 
 
 SCRIPTS=        				\

Modified: dab/trunk/changelog.Debian
===================================================================
--- dab/trunk/changelog.Debian	2010-08-17 14:01:38 UTC (rev 5028)
+++ dab/trunk/changelog.Debian	2010-08-19 07:00:48 UTC (rev 5029)
@@ -1,3 +1,9 @@
+dab (1.1-6) unstable; urgency=low
+
+  *  use mysql-server-5.1 for squeezs
+
+ -- Proxmox Support Team <support at proxmox.com>  Thu, 19 Aug 2010 08:32:57 +0200
+
 dab (1.1-5) unstable; urgency=low
 
   * bug fix: only print a warning for packages installed directly with



More information about the pve-devel mailing list