[pbs-devel] [PATCH proxmox-backup 1/2] client: backup spec: rename change detection mode default
Christian Ebner
c.ebner at proxmox.com
Fri Jun 7 15:12:50 CEST 2024
The currently default variant is named `Default`, which is not future
prove since the default might change in the future. So rename it to
`Legacy` instead.
Signed-off-by: Christian Ebner <c.ebner at proxmox.com>
---
pbs-client/src/backup_specification.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/pbs-client/src/backup_specification.rs b/pbs-client/src/backup_specification.rs
index 66bf71965..cd9e34243 100644
--- a/pbs-client/src/backup_specification.rs
+++ b/pbs-client/src/backup_specification.rs
@@ -54,7 +54,7 @@ pub fn parse_backup_specification(value: &str) -> Result<BackupSpecification, Er
pub enum BackupDetectionMode {
/// Encode backup as self contained pxar archive
#[default]
- Default,
+ Legacy,
/// Split backup mode, re-encode payload data
Data,
/// Compare metadata, reuse payload chunks if metadata unchanged
--
2.39.2
More information about the pbs-devel
mailing list