[pbs-devel] [PATCH proxmox-backup] fix #3934 tape owner-selector to Authid

Markus Frank m.frank at proxmox.com
Tue Mar 15 14:08:29 CET 2022


changed pmxUserSelector to pbsAuthidSelector, because it is currently
not possible to restore with a api token via gui.

Signed-off-by: Markus Frank <m.frank at proxmox.com>
---
 www/tape/window/TapeRestore.js | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/www/tape/window/TapeRestore.js b/www/tape/window/TapeRestore.js
index 7a5d3cbf..2322d352 100644
--- a/www/tape/window/TapeRestore.js
+++ b/www/tape/window/TapeRestore.js
@@ -398,10 +398,10 @@ Ext.define('PBS.TapeManagement.TapeRestoreWindow', {
 			    renderer: Ext.String.htmlEncode,
 			},
 			{
-			    xtype: 'pmxUserSelector',
+			    xtype: 'pbsAuthidSelector',
 			    name: 'owner',
 			    fieldLabel: gettext('Owner'),
-			    emptyText: gettext('Current User'),
+			    emptyText: gettext('Current Authentication'),
 			    value: null,
 			    allowBlank: true,
 			    skipEmptyText: true,
-- 
2.30.2





More information about the pbs-devel mailing list