[pbs-devel] [PATCH proxmox-backup 14/15] proxmox-rrd: rename last_counter to last_value
Dietmar Maurer
dietmar at proxmox.com
Wed Oct 13 10:24:51 CEST 2021
---
proxmox-rrd/src/rrd.rs | 25 +++++++++++++++----------
proxmox-rrd/src/rrd_v1.rs | 2 +-
2 files changed, 16 insertions(+), 11 deletions(-)
diff --git a/proxmox-rrd/src/rrd.rs b/proxmox-rrd/src/rrd.rs
index 7901fe39..72769bfd 100644
--- a/proxmox-rrd/src/rrd.rs
+++ b/proxmox-rrd/src/rrd.rs
@@ -63,7 +63,7 @@ pub struct DataSource {
pub last_update: f64,
/// Stores the last value, used to compute differential value for
/// derive/counters
- pub counter_value: f64,
+ pub last_value: f64,
}
impl DataSource {
@@ -72,7 +72,7 @@ impl DataSource {
Self {
dst,
last_update: 0.0,
- counter_value: f64::NAN,
+ last_value: f64::NAN,
}
}
@@ -94,23 +94,24 @@ impl DataSource {
if is_counter || self.dst == DST::Derive {
let time_diff = time - self.last_update;
- let diff = if self.counter_value.is_nan() {
+ let diff = if self.last_value.is_nan() {
0.0
} else if is_counter && value < 0.0 {
bail!("got negative value for counter");
- } else if is_counter && value < self.counter_value {
+ } else if is_counter && value < self.last_value {
// Note: We do not try automatic overflow corrections, but
- // we update counter_value anyways, so that we can compute the diff
+ // we update last_value anyways, so that we can compute the diff
// next time.
- self.counter_value = value;
+ self.last_value = value;
bail!("conter overflow/reset detected");
} else {
- value - self.counter_value
+ value - self.last_value
};
- self.counter_value = value;
value = diff/time_diff;
}
+ self.last_value = value;
+
Ok(value)
}
@@ -138,11 +139,15 @@ impl RRA {
}
}
- fn slot_end_time(&self, time: u64) -> u64 {
+ pub fn slot_end_time(&self, time: u64) -> u64 {
self.resolution*(time/self.resolution + 1)
}
- fn slot(&self, time: u64) -> usize {
+ pub fn slot_start_time(&self, time: u64) -> u64 {
+ self.resolution*(time/self.resolution)
+ }
+
+ pub fn slot(&self, time: u64) -> usize {
((time/self.resolution) as usize) % self.data.len()
}
diff --git a/proxmox-rrd/src/rrd_v1.rs b/proxmox-rrd/src/rrd_v1.rs
index 511b510b..7e4b97c2 100644
--- a/proxmox-rrd/src/rrd_v1.rs
+++ b/proxmox-rrd/src/rrd_v1.rs
@@ -285,7 +285,7 @@ impl RRDv1 {
let source = DataSource {
dst,
- counter_value: f64::NAN,
+ last_value: f64::NAN,
last_update: self.hour_avg.last_update, // IMPORTANT!
};
Ok(RRD {
--
2.30.2
More information about the pbs-devel
mailing list